Deprecated features

Deprecated features

Starting from V6.9, the Web API V1 is deprecated in favor of the more powerful and flexible Web API V2 (NXQL). Existing integrations will continue to work; Nexthink will communicate in advance before removing the Web API V1 from the product.

Q: What will happen to existing integrations using Web API V1?

  • A: For the moment they will continue to work. However, we recommend to migrate them to the Web API V2 (NXQL) whenever possible.

Q: I’m planning a new integration. Can I still use the Web API V1?

  • A: No. All new integrations must use the new Web API V2.